Scheduled Maintenance

Incident Report for Zenler

Resolved

During this maintenance window, we anticipate a very brief disconnection that will last less than 35 minutes in which the app and associated services may become temporarily unavailable.

Completed Feb 21, 2024, 03:05 UTC
The scheduled maintenance has been completed.
Posted Feb 21, 2024 - 02:30 UTC