The issue is now resolved. Users will be able to start uploading the video files now.
Posted May 04, 2023 - 10:31 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 04, 2023 - 09:34 UTC
Identified
We are currently experiencing some issues with the video hosting provider, Vimeo for new video embeds. (old video embeds are fine)
Vimeo has made changes to their API settings that affect video embeds, resulting in video does not exist errors on new video embeds when uploading new videos without any notice to all users and this means it affects embeds for new videos. You can also see the exact breaking change from Vimeo reported by several users on https://twitter.com/Vimeo.
Our tech team is already working on resolving this issue with urgent priority.